Finally Installed Lenny on Fuloong 2f mini

    I spent last two days searching and trying installation approach of debian on Fuloong mini. And just now I succeeded booting into the new shinning debian, which is extracted from a gzipped tar ball in http://bjlx.org.cn/loongson/ on a new partition.
    I’ve thought about other installation methods too. First, I tried to installed the system from a external cd-rom(The thinkpad DVD-RW Slim Poirtable Optical Drive). But after I press DEL and prompted with PMON>, the system kind of died there, not respond to any keyboard stroke.
    Then I tried to install from hard drive using the same ISO image downloaded from debian website(about 650MB). Because I saw there’re hd-media directory [1] figuring this will work like installation on x86 platform. However, after issued initrd, load and  g console=tty root=/dev/hda5, the machine died there and I have to hard reset the box.
    Finally, I decide to turn to the easiest installation method, downloading a pre-installed system and extracting it to a empty partition. The first gzipped tar ball I used is from [2]. But it encountered the same problem above, which means the system can’t boot after initrd and loading kernel. Probably because this tar ball is just for Yeeloong? Then I download the bzipped tar ball I use now and finally boot into the system. It’s really excited to see the familiar debian wall paper!!
    Why don’t I use the net installation described here[3]? That’s because I have to use PPPoE to connect to the ftp/http site, which is not supported in net installation. That’s why I want to include the full CD image of debian in installation described above becaued it is said on the debian installaion guide that only this image can boot the installed with pppoe support.
    And there is another thing to mention. It seems I have badblocks in one of the partition of fuloong mini. When I format a newly allocated 8G partion to hold the debian system, I encounterd the message:

ide: failed opcode was: unknown
end_request: I/O error, dev hda, sector blablabla
hda: task_in_intr: status=0x59 { DriveReady SeekComplete DataRequest Error }
hda: task_in_intr: error=0x01 { AddrMarkNotFound }, LBAsect=blablabla, sector=blablabla

The message repeated so many times that I have to cancel the process and allocate a new empty partition just after this one. I think I should contact Liu Qi about this problem and hopefully the bad block won’t grow.

Next, I’ll  prepare the systme to build the loongson optimized system.

[1]http://dev.lemote.com/debian-loongson/dists/loongson/main/installer-mipsel/current/images/lemote-fl/
[2]http://www.lemote.com/upfiles/OS/Debian-en/
[3]http://dev.lemote.com/drupal/node/58

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s


%d bloggers like this: